jump to navigation

…haven’t been riding… August 11, 2007

Posted by Chief in Bicycle, Biking, build, Culture, Equipment, homebrew, Photography, Photos, Rides.
trackback

I came down with Shingles a couple weeks ago. It attacked my L3 nerve bundle, which is the upper front to lower inner area on my left thigh. This has seriously hampered my ability (and motivation) to ride. After one misdiagnosis, and a week and a half, I’ve been prescribed some medication called Acyclovir which seems to be helping it out quite a bit. I take one 800mg pill every 6hrs for 7 days. I’ve managed to go to work (except for two days) and am otherwise productive. In fact, I’ve been cleaning and organizing my garage. Soon, I’ll have a workbench station setup just for bike maintenance.

I’ve also uploaded some pictures from my last weekend ride (back in July), and pictures of what happens when I don’t follow my own plans – and build a 50W Halogen spotlight that runs off 12VDC. Yeah, there could have been a fire, but man – it was a great light while it lasted!

Anyway, I should be back on the bike soon. I need to be, the Honolulu Century Ride is coming up at the end of September, and I want to ride the full 100 miles. Right now, I’m severely out of shape and have put on 14 pounds in the last month. Well, back on the bike soon enough. The shingles are phasing out of the pain stage and back to the crazy itchy stage, and the blisters are drying up. Gross. Another week and I’ll be riding again.

Advertisements

Comments»

No comments yet — be the first.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: